App Software Update

All the features listed are released in batches (groups of users) over the next couple of days.

We updated our time format from a military format to a 12-hour format which is updated in the scheduling, stats, and timestamp section. Here is a video for clarification.

With this update, overnight scheduling is easier, and if you want a 12-hour overnight light period, you would create the following cycle; 8:00 PM to 8:00 AM

We also launched a manual mode and a fan scheduling option. They’re in beta, so if you want an update sooner, please email

When the manual mode is activated, your grow recipe is paused, all outlets turn off and you can turn equipment on and off when needed. Lastly, you won’t be able to change certain configurations such as outlet configuration and climate offsets.

For your schedule, you’ll see a section in your grow recipe to input the number of minutes per hour you want your fan on. The fan will then turn on every hour (XX:03) for the number of minutes you entered. This will cycle for 24 hours of the day.

If there are questions (or feedback) please email or post your feedback here.


I could kiss you right now :kiss: shut up ! :astonished: … the 12Hr format just saved me so many brain cells!!! Also allowed for easy overnight cycle setting!!! . Just wow . Blows my mind how much feedback niwa takes from the community… finally a community that’s let’s the customers input matter! And actually makes changes. :astonished: wow :clap:

God I can’t wait to see where niwa is in 6 months and 1 year , I mean the possibles are endless.

Really From the buttom of my plants hearts . Thank you . Thank you. :blush: just wow :ok_hand:

Hey @Tttsss please email so we can see what’s happening, I’m not sure if I understood well

Hello! Regarding the new fan cycling functionality, please take into account that if you have a climate cycle set, the fan will keep working as usual, i.e. it will trigger when:

  • The temperature is above target and there is not an A/C trigger set

  • And/or the relative humidity is above target and there is not a dehumidifier set.

The new fan cycles setting will force the fan outlet ON for X minutes per hour, at the begging of every hour, and it will keep working according to the climate recipe after that period of time.

Please let us know if you have any questions, we will have some videos soon.

With the update I seem to be limited to two climate cycles? Is that a glitch? Also have temps showing in Fahrenheit even though my settings are set to Celsius.

Hello @DankNuggz, no it’s not, now you can create an overnight cycle + extra cycle, this equals to the old 3 cycles.

Please read next post regarding Celsius settings:

Warning for those using Celsius setting: One user just reported issues with the recipe’s editor while settings are in C, we are working on it right now, please switch to Fahrenheit to edit recipes until we are able to release the update.

We are sorry for the inconvenience.

Really appreciate the ability to program overnight cycles easily! Besides the reported “celcius” bug, I have noticed that when keeping the fan cycle setting at “0” minutes per hour, with the intention of keeping it continous, I can hear my fans go on/off spontaneously at the same minute every hour.

Thanks for the feedback @growqc with “with the intention of keeping it continuous,” do you mean keep it continuously working? If you set it to 0 it should not kick on. Please let me know.

By the way, we have updated our app to solve the Celsius recipe editor bug, and they are already available for iOS and Android, if you haven’t yet, please update your app, new version is v1.9.33

Tap the gear icon on the top right (within your dashboard) and you will see the version number on the bottom right). Also, is your phone an iPhone or Android?

Thanks for the quick fix on the celcius bug, now running v1.9.33, I am on iOS

Following your reply this morning, I edited my recipe and set the ventilation to 60 min per hour. In terms of UX experience, I was just expecting that not changing this value from its default 0 would keep the “minutes per hour” feature off, if that makes sense.

Still, I am getting the same behavior from the controller. Every :03 of the hour, I will hear my fan click off, then immediately back on again. I’m just expecting my exhaust to run continuously within a climate period (as it always did btw, what I am describing here is new behavior introduced by the latest dev update), unless it hits the environmental thresholds. Hope that clears up my explanation.

Thanks @growqc for the update and clarification, we will take it into account!

Hi there. Im in New Zealand and Niwa App does not appear in the Play store. Will this be likely in future of availible via website? Cheers.

Hello @Catchbag, please email, so we can find a solution for you ASAP

1 Like

In seeding stage I would like to keep as much of my heat and humidity as possible, yet still vent the tent for 2 minutes at the top of every hour. Can the NIWA do it? How?

Right now the niwa seems to be turning my exhaust fan on for 2 mins, then off for 2 mins, then on again/off again, every 2 minutes, regardless of temp and humidity parameters.

Please advise.
Thank you!:v:

Hello @awiniwa that’s weird, please email so we can have a closer look to it.